I faced this issue several times, and it appeared again yesterday. Here are the solution for this error. Invalid gemspec in [/opt/ruby/lib/ruby/gems/1.8/specifications/uniform_notifier-1.0.2.gemspec]: Illformed requirement ["# 3.0"] Invalid gemspec in [/opt/ruby/lib/ruby/gems/1.8/specifications/uniform_notifier-1.0.2.gemspec]: Illformed requirement ["# 3.0"]

As planned, Ruby 1.8.7 retired today, at the end of June, 2013. From now on, Ruby 1.8.7 is no longer supported in all senses (including features, bug fixes or security fixes) by the community. Technically speaking, it’s been a decade…

Rails has announced the availability of 3 news versions today,  3.2.13, 3.1.12, and 2.3.18, these releases contain important security fixes. It is recommended users upgrade as soon as possible.