Install Dell OMSA on Redhat Enterprise Linux

Dell LogoHere we listed 3 ways on the installation of Dell OpenManage Server Administrator on a Redhat Enterprise Linux, you can follows these steps on CentOS or SLES 10, they would work well.

1, Install from RPM packages
Generally we need these RPM packages, you can search and download them from Google.com.

[root@storage cax]# ls
srvadmin-cm-6.1.0-648.i386.rpm       srvadmin-omcommon-6.1.0-648.i386.rpm
srvadmin-deng-6.1.0-648.i386.rpm     srvadmin-omhip-6.1.0-648.i386.rpm
srvadmin-hapi-6.1.0-648.i386.rpm     srvadmin-omilcore-6.1.0-648.i386.rpm
srvadmin-isvc-6.1.0-648.i386.rpm     srvadmin-syscheck-6.1.0-648.i386.rpm
srvadmin-omacore-6.1.0-648.i386.rpm
srvadmin-cm-6.1.0-648.i386.rpm

These packages can be used on both RHEL-4 and RHEL-5. After the downloading, let’s start the installation:

[root@storage cax]# uname -a
Linux storage.admon 2.6.9-78.ELsmp #1 SMP Wed Jul 9 15:46:26 EDT 2008 x86_64 x86_64 x86_64 GNU/Linux
[root@storage cax]# rpm -ivh srv*.rpm
Preparing...                ########################################### [100%]
1:srvadmin-omilcore      ########################################### [ 11%]
To start all installed services without a reboot,
enter the following command:  srvadmin-services.sh  start
2:srvadmin-syscheck      ########################################### [ 22%]
3:srvadmin-deng          ########################################### [ 33%]
4:srvadmin-hapi          ########################################### [ 44%]
5:srvadmin-omcommon      ########################################### [ 56%]
6:srvadmin-omacore       ########################################### [ 67%]
7:srvadmin-isvc          ########################################### [ 78%]
8:srvadmin-cm            ########################################### [ 89%]
9:srvadmin-omhip         ########################################### [100%]
[root@storage cax]#

Now, it’s ready for use! enjoy!

The following two steps are from Dell’s official website, and it’s officially supported by Dell!

2, Setup for usage with yum

The minimum required yum is 2.4.x, and it’s tested on RHEL5, CentOS, Scientific Linux, RHEL4+yum, SLES+yum. The version of yum distributed on CentOS 3 by default is very old (yum 2.0.8), so you need to upgrade to a 2.4.x version in order to use these repositories. The older version of yum does not support plugins or mirrorlists, which are required for these repos to work.

Set up this repository, type:

[root@storage cax]# wget -q -O - http://linux.dell.com/repo/hardware/OMSA_6.1/bootstrap.cgi | bash

Optional Install OpenManage Server Administrator:

[root@storage cax]# yum install srvadmin-all

NOTE: OMSA will not install on unsupported systems. If you receive a message at install that the system is not supported, it is likely that your system is not supported, and the install will fail. This is most common on Dell SC-class systems, as OMSA is completely unsupported on these systems.

3, Set up for usage with up2date

Follow these instructions for use with up2date on RHEL4:

Set up this repository:

[root@storage cax]# wget -q -O - http://linux.dell.com/repo/hardware/OMSA_6.1/bootstrap.cgi | bash

Optional Install OpenManage Server Administrator:

[root@storage cax]# up2date -i srvadmin-all

NOTE: OMSA will not install on unsupported systems. If you receive a message at install that the system is not supported, it is likely that your system is not supported, and the install will fail. This is most common on SC-class systems, as OMSA is completely unsupported on these systems.

Share Button

One thought on “Install Dell OMSA on Redhat Enterprise Linux

Leave a comment

Your email address will not be published. Required fields are marked *